Hôm nay, T.Hai Tháng 10 23, 2017 2:44 pm

Múi giờ UTC + 7 Giờ





Tạo chủ đề mới Gửi bài trả lời  [ 3 bài viết ] 
Người gửi Nội dung
 Tiêu đề bài viết: Rất mong bạn camaptrang có thể trả lời giúp mình lỗi này?
Gửi bàiĐã gửi: T.Tư Tháng 5 29, 2013 5:53 pm 
Ngoại tuyến

Ngày tham gia: T.Tư Tháng 5 29, 2013 4:36 pm
Bài viết: 2
Mình đang học hỏi cài mấy phần mềm giám sát băng thông, cảnh báo như là mrtg, nagios...
Thấy tài liệu của bạn viết rất hay và tỉ mỉ, mình cũng làm theo y như bạn nhưng đã gặp phải 1 số lỗi như sau:
1. Đầu tiên mình dùng bản CentOS 4.4 nhưng do bản này cũ quá và đã hết hạn nên mình không thể dùng lệnh yum để cài đặt được, vì thể mình nâng cấp và tải bản 6.4 mới nhất, 32 bit về cài lại, do máy mình RAM yếu lên mình dùng bản 32 bit mà không dùng bản 64 bit, khi mình dùng bản CentOS 6.4, 3 bit để cài đặt cacti thì do bản này mới nên nó cứ yêu cầu cài rất nhiều gói mới hơn, mỗi lần mình lại tải về thì mất rất nhiều thời gian, chẳng hạn mình cũng dung winscp như của bạn, tải bản rrdtool về, sau đó copy từ máy window sang linux, rồi tiến hành cài trên putty bằng lệnh rpm -ivh rrdtool-1.4.7-1.el5.rf.i386.rpm, đây là bản mới nhất lên máy cen báo là phải yêu cầu cài các gói sau error: Failed dependencies:
lua is needed by rrdtool-1.4.7-1.el5.rf.i386
ruby is needed by rrdtool-1.4.7-1.el5.rf.i386

- Mình lại tiến hành down từng gói 1 về rồi lại cài thì gói đó lại yêu cầu cài các cái khác, cứ như thế rất mất thời gian, vì vậy mong bạn và mọi người có cách nào dùng lệnh Yum để cài mà vẫn cập nhật được bản mới về không?
- Thấy mất thời gian, vì thế mình tải bản CentOS 5.4 về và cài trên máy ảo, mình cũng tải bản rrdtool mới nhất 1.4.7 thì thông báo cũng như bản centos 6.4, rồi sau đó mình tải bản 1.2.18 như video hướng dẫn cài cacti của bạn camaptrang, thì máy không yêu cầu phải cài lua hay ruby nữa, nhưng bản này quá cũ hơn bản 1.4.7 nên mình sợ sẽ không có nhiều ưu điểm, thế là mình cài không mắc 1 lỗi gì như video bạn cá cập hướng dẫn với bản 1.2.18, nhưng đến phần http://ip ipwebserver/cacti thì mình không thấy báo lỗi, không thấy hiển thị cacti lên cả.
- Vậy bạn camap và mọi người có thể cho mình hỏi: +nguyên nhân do lỗi gì vậy?
+ Mình điền địa chỉ IP của webserver chính là địa chỉ của máy chủ centos, mình chạy firefox trên máy winxp3, mình đã ping từ máy xp3 đến máy centos đều thông cả.
+ Mình chuyển sang chế độ đồ họa bằng lệnh init 5, rồi vào fire fox của máy linux, gõ ipwebserver/cacti thì cũng không hiển thị cacti.
+Bạn camap và mọi người có thể cho mình hỏi thêm, mình chạy đồ thì này trên trình duyệt web IE, chrom có được không? hay nhất thiết mình phải chạy trên fire fox như bạn video bạn camap hướng dẫn thì mới được?
3. Điều thứ 3 cho mình hỏi bạn camap làm video hướng dẫn mrtg trên centos, nhưng mình vào thì báo quyền riêng tư là sao hả bạn? Bạn có thế cho mình xin tài khoản, fb, địa chỉ để mình chuyển khoản tới bạn có được không? để mình có thể xem được video này và hy vọng bạn có thời gian làm thêm 1 video hướng dẫn cài và cấu hình nagios để giám sát, cảnh báo hệ thống? Mình sẵn sàng chuyển khoản nếu bạn cần...
Cảm ơn bạn và mọi người nhiều!


Đầu trang
 Xem thông tin cá nhân  
 
 Tiêu đề bài viết: Re: Rất mong bạn camaptrang có thể trả lời giúp mình lỗi này?
Gửi bàiĐã gửi: T.Tư Tháng 5 29, 2013 10:10 pm 
Ngoại tuyến

Ngày tham gia: T.Bảy Tháng 8 28, 2010 2:28 pm
Bài viết: 1075
hieurau123 đã viết:
Mình đang học hỏi cài mấy phần mềm giám sát băng thông, cảnh báo như là mrtg, nagios...
Thấy tài liệu của bạn viết rất hay và tỉ mỉ, mình cũng làm theo y như bạn nhưng đã gặp phải 1 số lỗi như sau:
1. Đầu tiên mình dùng bản CentOS 4.4 nhưng do bản này cũ quá và đã hết hạn nên mình không thể dùng lệnh yum để cài đặt được, vì thể mình nâng cấp và tải bản 6.4 mới nhất, 32 bit về cài lại, do máy mình RAM yếu lên mình dùng bản 32 bit mà không dùng bản 64 bit, khi mình dùng bản CentOS 6.4, 3 bit để cài đặt cacti thì do bản này mới nên nó cứ yêu cầu cài rất nhiều gói mới hơn, mỗi lần mình lại tải về thì mất rất nhiều thời gian, chẳng hạn mình cũng dung winscp như của bạn, tải bản rrdtool về, sau đó copy từ máy window sang linux, rồi tiến hành cài trên putty bằng lệnh rpm -ivh rrdtool-1.4.7-1.el5.rf.i386.rpm, đây là bản mới nhất lên máy cen báo là phải yêu cầu cài các gói sau error: Failed dependencies:
lua is needed by rrdtool-1.4.7-1.el5.rf.i386
ruby is needed by rrdtool-1.4.7-1.el5.rf.i386

- Mình lại tiến hành down từng gói 1 về rồi lại cài thì gói đó lại yêu cầu cài các cái khác, cứ như thế rất mất thời gian, vì vậy mong bạn và mọi người có cách nào dùng lệnh Yum để cài mà vẫn cập nhật được bản mới về không?
- Thấy mất thời gian, vì thế mình tải bản CentOS 5.4 về và cài trên máy ảo, mình cũng tải bản rrdtool mới nhất 1.4.7 thì thông báo cũng như bản centos 6.4, rồi sau đó mình tải bản 1.2.18 như video hướng dẫn cài cacti của bạn camaptrang, thì máy không yêu cầu phải cài lua hay ruby nữa, nhưng bản này quá cũ hơn bản 1.4.7 nên mình sợ sẽ không có nhiều ưu điểm, thế là mình cài không mắc 1 lỗi gì như video bạn cá cập hướng dẫn với bản 1.2.18, nhưng đến phần http://ip ipwebserver/cacti thì mình không thấy báo lỗi, không thấy hiển thị cacti lên cả.
- Vậy bạn camap và mọi người có thể cho mình hỏi: +nguyên nhân do lỗi gì vậy?
+ Mình điền địa chỉ IP của webserver chính là địa chỉ của máy chủ centos, mình chạy firefox trên máy winxp3, mình đã ping từ máy xp3 đến máy centos đều thông cả.
+ Mình chuyển sang chế độ đồ họa bằng lệnh init 5, rồi vào fire fox của máy linux, gõ ipwebserver/cacti thì cũng không hiển thị cacti.
+Bạn camap và mọi người có thể cho mình hỏi thêm, mình chạy đồ thì này trên trình duyệt web IE, chrom có được không? hay nhất thiết mình phải chạy trên fire fox như bạn video bạn camap hướng dẫn thì mới được?
3. Điều thứ 3 cho mình hỏi bạn camap làm video hướng dẫn mrtg trên centos, nhưng mình vào thì báo quyền riêng tư là sao hả bạn? Bạn có thế cho mình xin tài khoản, fb, địa chỉ để mình chuyển khoản tới bạn có được không? để mình có thể xem được video này và hy vọng bạn có thời gian làm thêm 1 video hướng dẫn cài và cấu hình nagios để giám sát, cảnh báo hệ thống? Mình sẵn sàng chuyển khoản nếu bạn cần...
Cảm ơn bạn và mọi người nhiều!


Bạn có thể cài từng bước step by step như trong bài hướng dẫn là có thể cài hoàn tất Cacti.

để tránh việc cài hay bị đòi hỏi gói update bạn sử dụng lệng #yum update trước khi bắt đầu cài đặt.

Về phần lỗi khi cài rrdtool không thành công là do bạn cài riêng từ gói trong bước này:

Cài đặt rrdtool
Trích dẫn:
#wget http://packages.sw.be/rrdtool/rrdtool-1 ... f.i386.rpm
#wget http://packages.sw.be/rrdtool/perl-rrdt ... f.i386.rpm
#wget http://packages.sw.be/rrdtool/rrdtool-d ... f.i386.rpm

rpm -ivh rrdtool-1.2.18-1.el5.rf.i386.rpm perl-rrdtool-1.2.18-1.el5.rf.i386.rpm rrdtool-devel-1.2.18-1.el5.rf.i386.rpm


Bạn chú ý đến dòng cài sau nhé, vì nếu cài riêng từng gói sẽ bị báo lỗi :

rpm -ivh rrdtool-1.2.18-1.el5.rf.i386.rpm perl-rrdtool-1.2.18-1.el5.rf.i386.rpm rrdtool-devel-1.2.18-1.el5.rf.i386.rpm

hieurau123 đã viết:
+ Mình chuyển sang chế độ đồ họa bằng lệnh init 5, rồi vào fire fox của máy linux, gõ ipwebserver/cacti thì cũng không hiển thị cacti.


Bạn kiểm tra lại xem coi đã cài và start php trên máy chủ cacti thành công chưa ?
Và kiểm tra xem coi Cacti services đã start và có quyền trên cơ sở dữ liệu mysql ?

hieurau123 đã viết:
3. Điều thứ 3 cho mình hỏi bạn camap làm video hướng dẫn mrtg trên centos, nhưng mình vào thì báo quyền riêng tư là sao hả bạn? Bạn có thế cho mình xin tài khoản, fb, địa chỉ để mình chuyển khoản tới bạn có được không? để mình có thể xem được video này và hy vọng bạn có thời gian làm thêm 1 video hướng dẫn cài và cấu hình nagios để giám sát, cảnh báo hệ thống? Mình sẵn sàng chuyển khoản nếu bạn cần...
Cảm ơn bạn và mọi người nhiều!


à do là mình cái vài việc riêng và đang edit lại các video đó nên bữa rồi để chế độ riêng tư, do bận quá nên quên làm, giờ bạn nhắc mới nhớ, để tranh thủ làm rồi sẽ upload lại ngay.

Tiền bạc không phải là vấn đề chính của việc này bạn à ! nếu bạn có hứng thú đóng góp cho cộng đồng những kinh nghiệm và kiến thức bằng những chia sẽ là quí báu nhất rồi.

_________________
Cung cấp Server, thiết bị linh kiện mạng và voip với nguồn nhập USA về bảo đảm về chất lượng và giá cả lẫn dịch vụ hỗ trợ.
Liên hệ: phong.le@asterisk.vn - 0983077440
http://www.servergiare.com.vn


Đầu trang
 Xem thông tin cá nhân  
 
 Tiêu đề bài viết: Re: Rất mong bạn camaptrang có thể trả lời giúp mình lỗi này
Gửi bàiĐã gửi: T.Năm Tháng 5 30, 2013 8:43 am 
Ngoại tuyến

Ngày tham gia: T.Tư Tháng 5 29, 2013 4:36 pm
Bài viết: 2
camaptrang đã viết:
hieurau123 đã viết:
Mình đang học hỏi cài mấy phần mềm giám sát băng thông, cảnh báo như là mrtg, nagios...
Thấy tài liệu của bạn viết rất hay và tỉ mỉ, mình cũng làm theo y như bạn nhưng đã gặp phải 1 số lỗi như sau:
1. Đầu tiên mình dùng bản CentOS 4.4 nhưng do bản này cũ quá và đã hết hạn nên mình không thể dùng lệnh yum để cài đặt được, vì thể mình nâng cấp và tải bản 6.4 mới nhất, 32 bit về cài lại, do máy mình RAM yếu lên mình dùng bản 32 bit mà không dùng bản 64 bit, khi mình dùng bản CentOS 6.4, 3 bit để cài đặt cacti thì do bản này mới nên nó cứ yêu cầu cài rất nhiều gói mới hơn, mỗi lần mình lại tải về thì mất rất nhiều thời gian, chẳng hạn mình cũng dung winscp như của bạn, tải bản rrdtool về, sau đó copy từ máy window sang linux, rồi tiến hành cài trên putty bằng lệnh rpm -ivh rrdtool-1.4.7-1.el5.rf.i386.rpm, đây là bản mới nhất lên máy cen báo là phải yêu cầu cài các gói sau error: Failed dependencies:
lua is needed by rrdtool-1.4.7-1.el5.rf.i386
ruby is needed by rrdtool-1.4.7-1.el5.rf.i386

- Mình lại tiến hành down từng gói 1 về rồi lại cài thì gói đó lại yêu cầu cài các cái khác, cứ như thế rất mất thời gian, vì vậy mong bạn và mọi người có cách nào dùng lệnh Yum để cài mà vẫn cập nhật được bản mới về không?
- Thấy mất thời gian, vì thế mình tải bản CentOS 5.4 về và cài trên máy ảo, mình cũng tải bản rrdtool mới nhất 1.4.7 thì thông báo cũng như bản centos 6.4, rồi sau đó mình tải bản 1.2.18 như video hướng dẫn cài cacti của bạn camaptrang, thì máy không yêu cầu phải cài lua hay ruby nữa, nhưng bản này quá cũ hơn bản 1.4.7 nên mình sợ sẽ không có nhiều ưu điểm, thế là mình cài không mắc 1 lỗi gì như video bạn cá cập hướng dẫn với bản 1.2.18, nhưng đến phần http://ip ipwebserver/cacti thì mình không thấy báo lỗi, không thấy hiển thị cacti lên cả.
- Vậy bạn camap và mọi người có thể cho mình hỏi: +nguyên nhân do lỗi gì vậy?
+ Mình điền địa chỉ IP của webserver chính là địa chỉ của máy chủ centos, mình chạy firefox trên máy winxp3, mình đã ping từ máy xp3 đến máy centos đều thông cả.
+ Mình chuyển sang chế độ đồ họa bằng lệnh init 5, rồi vào fire fox của máy linux, gõ ipwebserver/cacti thì cũng không hiển thị cacti.
+Bạn camap và mọi người có thể cho mình hỏi thêm, mình chạy đồ thì này trên trình duyệt web IE, chrom có được không? hay nhất thiết mình phải chạy trên fire fox như bạn video bạn camap hướng dẫn thì mới được?
3. Điều thứ 3 cho mình hỏi bạn camap làm video hướng dẫn mrtg trên centos, nhưng mình vào thì báo quyền riêng tư là sao hả bạn? Bạn có thế cho mình xin tài khoản, fb, địa chỉ để mình chuyển khoản tới bạn có được không? để mình có thể xem được video này và hy vọng bạn có thời gian làm thêm 1 video hướng dẫn cài và cấu hình nagios để giám sát, cảnh báo hệ thống? Mình sẵn sàng chuyển khoản nếu bạn cần...
Cảm ơn bạn và mọi người nhiều!


Bạn có thể cài từng bước step by step như trong bài hướng dẫn là có thể cài hoàn tất Cacti.

để tránh việc cài hay bị đòi hỏi gói update bạn sử dụng lệng #yum update trước khi bắt đầu cài đặt.

Về phần lỗi khi cài rrdtool không thành công là do bạn cài riêng từ gói trong bước này:

Cài đặt rrdtool
Trích dẫn:
#wget http://packages.sw.be/rrdtool/rrdtool-1 ... f.i386.rpm
#wget http://packages.sw.be/rrdtool/perl-rrdt ... f.i386.rpm
#wget http://packages.sw.be/rrdtool/rrdtool-d ... f.i386.rpm

rpm -ivh rrdtool-1.2.18-1.el5.rf.i386.rpm perl-rrdtool-1.2.18-1.el5.rf.i386.rpm rrdtool-devel-1.2.18-1.el5.rf.i386.rpm


Bạn chú ý đến dòng cài sau nhé, vì nếu cài riêng từng gói sẽ bị báo lỗi :

rpm -ivh rrdtool-1.2.18-1.el5.rf.i386.rpm perl-rrdtool-1.2.18-1.el5.rf.i386.rpm rrdtool-devel-1.2.18-1.el5.rf.i386.rpm

hieurau123 đã viết:
+ Mình chuyển sang chế độ đồ họa bằng lệnh init 5, rồi vào fire fox của máy linux, gõ ipwebserver/cacti thì cũng không hiển thị cacti.


Bạn kiểm tra lại xem coi đã cài và start php trên máy chủ cacti thành công chưa ?
Và kiểm tra xem coi Cacti services đã start và có quyền trên cơ sở dữ liệu mysql ?

hieurau123 đã viết:
3. Điều thứ 3 cho mình hỏi bạn camap làm video hướng dẫn mrtg trên centos, nhưng mình vào thì báo quyền riêng tư là sao hả bạn? Bạn có thế cho mình xin tài khoản, fb, địa chỉ để mình chuyển khoản tới bạn có được không? để mình có thể xem được video này và hy vọng bạn có thời gian làm thêm 1 video hướng dẫn cài và cấu hình nagios để giám sát, cảnh báo hệ thống? Mình sẵn sàng chuyển khoản nếu bạn cần...
Cảm ơn bạn và mọi người nhiều!


à do là mình cái vài việc riêng và đang edit lại các video đó nên bữa rồi để chế độ riêng tư, do bận quá nên quên làm, giờ bạn nhắc mới nhớ, để tranh thủ làm rồi sẽ upload lại ngay.

Tiền bạc không phải là vấn đề chính của việc này bạn à ! nếu bạn có hứng thú đóng góp cho cộng đồng những kinh nghiệm và kiến thức bằng những chia sẽ là quí báu nhất rồi.



Chào bạn camaptrang!

- Thực sự xin lỗi bạn là hôm qua mình không tìm thấy mục gửi đâu lên mình mới thử viết 1 topic thí điểm đâm ra mới hiện bài viết lỗi, hôm nay mình đã vào để xóa nhưng mình tìm mãi mà không thấy mục xóa đâu cả, rất mong sự hướng dẫn của bạn, có thể mod soạn thảo bạn cài chế độ xóa nằm ẩn hay ở đâu đó.
- Rất cảm ơn sự hồi câm của bạn.
- Mình cũng đã chạy yum update rồi bạn ạ, nhưng máy chủ linux vẫn báo thế bạn ạ.
- Mình cũng đã cài gói #rpm -ivh rrdtool-1.2.18-1.el5.rf.i386.rpm , sau khi mình copy 3 bản rrdtool, per, rrdtool-dev 1.2.18 từ máy winscp sang máy linux, sau khi dùng lệnh #rpm -ivh rrdtool-1.2.18-1.el5.rf.i386.rpm trên putty thì máy yêu cầu cài perl thì mình lại cách ra và ấn per 1.2.18, rồi mình lại cách ra ấn rrdtool-dev cuối cùng được 3 gói hoàn chỉnh rpm -ivh rrdtool-1.2.18-1.el5.rf.i386.rpm perl-rrdtool-1.2.18-1.el5.rf.i386.rpm rrdtool-devel-1.2.18-1.el5.rf.i386.rpm và cài đặt bình thường, mình làm y như video hướng dẫn cài cacti của bạn và không mắc 1 lỗi gì, đến phần đánh địa chỉ IP trên firefox lúc đầu bạn làm trên video không hiện, nhưng bạn dùng 2 lệnh /etc/init.d/httpd restart/etc/init.d/iptables stop thì cacti hiển thị lên fire fox, còn mình cũng làm y như bạn nhưng lại không thấy báo lỗi, không thấy hiển thị gì cả mà chỉ thấy hình màu vuông có hình nét đứt ở phía logo trình duyệt.
- Chỉ có 1 điều là mình không làm được như video hướng dẫn của bạn là mình dùng lệnh yum install php* thì máy báo lỗi Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos-hn.viettelidc.com.vn
* extras: centos-hn.viettelidc.com.vn
* updates: centos-hn.viettelidc.com.vn
Setting up Install Process

Package php-snmp-5.1.6-39.el5_8.i386 already installed and latest version
Package php-dbase is obsoleted by php-common, trying to install php-common-5.1.6-39.el5_8.i386 instead
máy nói bản php-snmp-5.1.6-39.el5_8.i386 đã cài đặt rồi nhưng phiên bản này quá cũ thử cài bản php-common-5.1.6-39.el5_8.i386 xem sao, mặc dù mình đã dùng lệnh yum update rồi nhưng máy vẫn báo thế. Mình đã dùng lệnh vi /etc/yum.repos.d/CentOS-Base.repo
để chỉnh sửa mục base thành 127.0.0.1 nhưng vẫn không cài được *php, máy cứ tìm máy chủ gần nhất là centos-hn.viettelidc.com.vn, mà theo mình đoán có lẽ máy chủ này gặp lỗi.
- Sau đó mình dùng lệnh yum install php thì cài được nhưng mỗi tội chỉ cài được mỗi php thôi, còn nếu dùng lệnh yum install php* như bạn làm trong video thì cài được 25/25 gói cơ. Liệu như vậy thì có ảnh hưởng gì không bạn?
- Bạn có thể hướng dẫn mình dùng lệnh start php và kiểm tra xem Cacti services đã start và có quyền trên cơ sở dữ liệu mysql có được không?
- Điều thứ 3 rất mong được xem video hướng dẫn cài đặt mrtg của bạn trong thời gian sớm nhất.
- Mình mới học lên kiến thức yếu kém có gì mong các bạn và bạn camaptrang hướng dẫn giúp mình, mình, mình biết 1 chút về quản trị hệ thống như switch và router, nếu có thể mình có thể đóng góp 1 chút nhỏ vào diễn đàn.
- Bạn cá mập trắng có ở HN không bạn? Nếu không ở HN thì bạn có dịp nào ra hn không vậy? Rất mong có ngày được mời bạn đi cafe nếu bạn rảnh.

Cảm ơn bạn và mọi người nhiều. :)


Đầu trang
 Xem thông tin cá nhân  
 
Hiển thị bài viết cách đây:  Sắp xếp theo  
Tạo chủ đề mới Gửi bài trả lời  [ 3 bài viết ] 

Múi giờ UTC + 7 Giờ


Đang trực tuyến

Đang xem chuyên mục này: Không có thành viên nào trực tuyến.1 khách.


Bạn không thể tạo chủ đề mới.
Bạn không thể trả lời bài viết.
Bạn không thể sửa những bài viết của mình.
Bạn không thể xóa những bài viết của mình.
Bạn không thể gửi tập tin đính kèm.

Tìm với từ khóa:
Chuyển đến:  
Powered by The Vietnam Asterisk User Group © 2008