Hôm nay, T.Ba Tháng 9 26, 2017 1:45 am

Múi giờ UTC + 7 Giờ





Tạo chủ đề mới Gửi bài trả lời  [ 1 bài viết ] 
Người gửi Nội dung
 Tiêu đề bài viết: Cấu hình cơ bản IP telephony trong Packet Tracer 5.3
Gửi bàiĐã gửi: CN Tháng 12 23, 2012 12:36 am 
Ngoại tuyến

Ngày tham gia: T.Bảy Tháng 8 28, 2010 2:28 pm
Bài viết: 1075
Mô tải bài Lab

Hướng dẫn này được thiết kế để giúp cấu hình các tính năng voice over ip (VoIP) mới có sẵn trong Packet Tracer 5,3. Nó sẽ hiển thị cho bạn các bước cần thiết để:

  • Cấu hình Call Manager Express trên một router 2811.
  • Sử dụng các thiết bị điện thoại khác nhau.
  • Setup dial peers
  • Kết nối Cisco IP phones cũng như các điện thoại tương tự khác trong mạng.

Network diagram

Hình ảnh
Lưu ý: Bắt đầu làm lab chỉ kết nối chỉ IP Phone 1. IP Phone 2 phải ngắt kết nối.

Bước 1 : Cấu hình interface FastEthernet 0/0 và DHCP server trên RouterA (2811 router)

    #Configure the FA 0/0 interface#
    RouterA>enable
    RouterA#configure terminal
    RouterA(config)#interface FastEthernet0/0
    RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
    RouterA(config-if)#no shutdown

Máy chủ DHCP để cung cấp địa chỉ IP và máy chủ TFTP nội bộ cho mỗi điện thoại IP kết nối vào.

    RouterA(config)#ip dhcp pool VOICE #Create DHCP pool named VOICE
    RouterA(dhcp-config)#network 192.168.10.0 255.255.255.0 #DHCP network network 192.168.10 with /24 mask#
    RouterA(dhcp-config)#default-router 192.168.10.1 #The default router IP address#
    RouterA(dhcp-config)#option 150 ip 192.168.10.1 #Mandatory for voip configuration.

Sau khi cấu hình xong, chờ một thời gian ngắn và kiểm tra xem là IP Phone 1 đã được nhận địa chỉ IP chưa bằng cách đặt con trỏ chuột lên điện thoại cho đến khi một bản tóm tắt cấu hình xuất hiện.

Bước 2 : Cấu hình Call Manager Express telephony service trên RouterA

Bây giờ chúng ta phải cấu hình dịch vụ điện thoại Call Manager Express trên RouterA để cho phép voip trên mạng.

    RouterA(config)#telephony-service #Configuring the router for telephony services#
    RouterA(config-telephony)#max-dn 5 #Define the maximum number of directory numbers#
    RouterA(config-telephony)#max-ephones 5 #Define the maximum number of phones#
    RouterA(config-telephony)#ip source-address 192.168.10.1 port 2000 #IP Address source#
    RouterA(config-telephony)#auto assign 4 to 6 #Automatically assigning ext numbers to buttons#
    RouterA(config-telephony)#auto assign 1 to 5 #Automatically assigning ext numbers to buttons#

Bước 3 : Cấu hình một vlan cho voice trên SwitchA

Áp dụng cấu hình sau đây trên giao diện SwitchA. Cấu hình này sẽ tách lưu lượng thoại và dữ liệu truy cập trong các VLAN khác nhau trên SwitchA. data packets sẽ được thực hiện trên các access vlan.

    SwitchA(config)#interface range fa0/1 – 5 #Configure interface range#
    SwitchA(config-if-range)#switchport mode access
    SwitchA(config-if-range)#switchport voice vlan 1 #Define the VLAN on which voice packets will be handled#

Bước 4 : Cấu hình thư mục điện thoại cho điện thoại IP Phone 1

Mặc dù IP-Phone 1 đã được kết nối với SwitchA, nó cần cấu hình thêm trước khi bắt đầu để giao tiếp. Bạn cần phải cấu hình RouterA CME gán một số điện cho điện thoại IP-Phone này.

    RouterA(config)#ephone-dn 1 #Defining the first directory entry#
    RouterA(config-ephone-dn)#number 54001 #Assign the phone number to this entry#

Bước 5 : Xác thực cấu hình

Đảm bảo rằng điện thoại IP-Phone nhận được một địa chỉ IP và một số điện thoại 54001 từ RouterA (điều này có thể mất một thời gian ngắn).

Hình ảnh

Hình ảnh

Bước 6 : Cấu hình Thư mục điện thoại cho IP-Phone 2

Kết nối điện thoại IP-Phone 2 tới SwitchA và sử dụng power adaptor cấp nguồn cho điện thoại này (cách cấu hình xem thêm bài viết Packet Tracer 5.3 - IP telephony devices).

    RouterA(config)#ephone-dn 2 #Defining the first directory entry#
    RouterA(config-ephone-dn)#number 54002 #Assign the phone number to this entry#

Bước 7 : Xác thực cấu hình

Làm tương tự như bước 5 để đảm bảo Điện thoại IP-Phone 2 nhận được một địa chỉ IP và một số điện thoại 54002 từ RouterA (có thể mất một thời gian ngắn).

Quay số gọi 54001 và kiểm tra xem nếu điện thoại IP-Phone 1 nhận được cuộc gọi.

Tham khảo bài viết Packet Tracer 5.3 - IP telephony devices

Download Packet Tracer 5.3

_________________
Cung cấp Server, thiết bị linh kiện mạng và voip với nguồn nhập USA về bảo đảm về chất lượng và giá cả lẫn dịch vụ hỗ trợ.
Liên hệ: phong.le@asterisk.vn - 0983077440
http://www.servergiare.com.vn


Đầu trang
 Xem thông tin cá nhân  
 
Hiển thị bài viết cách đây:  Sắp xếp theo  
Tạo chủ đề mới Gửi bài trả lời  [ 1 bài viết ] 

Múi giờ UTC + 7 Giờ


Đang trực tuyến

Đang xem chuyên mục này: Không có thành viên nào trực tuyến.1 khách.


Bạn không thể tạo chủ đề mới.
Bạn không thể trả lời bài viết.
Bạn không thể sửa những bài viết của mình.
Bạn không thể xóa những bài viết của mình.
Bạn không thể gửi tập tin đính kèm.

Tìm với từ khóa:
Chuyển đến:  
cron
Powered by The Vietnam Asterisk User Group © 2008